use strict;
my $str = '$a, $b, $c, $hi = "", $na';
my $regex = qr/(?<=\$[A-Za-z0-9\-\_ ]+)(?=(?:,|$))/ip;
my $subst = ' = NULL';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";