import Foundation
let pattern = #"(?<=\$[A-Za-z0-9\-\_ ]+)(?=(?:,|$))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"$a, $b, $c, $hi = "", $na"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" = NULL"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)