import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(### EXAMPLE ([0-9|[0-9]+))\\n(```\\n(```|```ps|```posh|```powershell)\\n```\\n)\\n([\\s\\S]*?)\\\\`\\\\`\\\\`(\\n\\n|\\n)([\\s\\S]*|\\n)";
final String string = "### EXAMPLE 123\n"
+ "```\n"
+ "```powershell\n"
+ "```\n\n"
+ "$powershellVersion = '6 and lower'\n"
+ "$description = 'custom code fencing example WITH markdown description'\n"
+ "$names | Foreach-Object {} {\n"
+ " write-host 'indentation is respected'\n"
+ " Write-Host 'enormously long lines should not get cut off by our PlatyPS friends, ftw'\n"
+ "}\n\n"
+ "$emptyNewlinesInCode = $True\n"
+ "\\`\\`\\`\n\n"
+ "The description would continue after first closing code fence.\n\n"
+ "This solution:\n\n"
+ "- respects indentation\n"
+ "- will treat description as markdown\n"
+ "- seems close to what comes natural\n\n"
+ "With this solution, the description itself could even contain code blocks:\n\n"
+ "\\`\\`\\`js\n"
+ "$var = docusaurus.New($config);\n"
+ "\\`\\`\\`\n\n"
+ "Pretty cool and the console becomes more readable too IMO, at least\n"
+ "you now see where the code ends and the explanation begins\n\n"
+ "\\`\\`\\`\n"
+ "$unMonicked = \"should stay unmonicked, in other words powershell should not be added\"\n"
+ " $indentationRespected = $True\n"
+ "$theBadNews - \"that PlatyPS seems to cut off this line if a .\n"
+ "is detected, wtf\"\n"
+ "\\`\\`\\`";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}