#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\(Person in \(\s*\d+\s*(?:,\s*\d+\s*)*\)\)"
Local $sString = "location = "Somewhere" and (Person IN (4,1)) and status in ("Closed")" & @CRLF & _
"" & @CRLF & _
"location = "Somewhere" and (Person IN ( 4, 1,8,2, 10,24 ,32,15, 7 )) and status in ("Closed")" & @CRLF & _
"" & @CRLF & _
"location = "Somewhere" and (Person IN ()) and status in ("Closed")" & @CRLF & _
"" & @CRLF & _
"location = "Somewhere" and (Person IN ( 4 )) and status in ("Closed")" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")