// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\(Person in \(\s*\d+\s*(?:,\s*\d+\s*)*\)\)").unwrap();
let string = "location = \"Somewhere\" and (Person IN (4,1)) and status in (\"Closed\")
location = \"Somewhere\" and (Person IN ( 4, 1,8,2, 10,24 ,32,15, 7 )) and status in (\"Closed\")
location = \"Somewhere\" and (Person IN ()) and status in (\"Closed\")
location = \"Somewhere\" and (Person IN ( 4 )) and status in (\"Closed\")
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}