using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(src|href)=""([0-9a-zA-Z_\-\/]+\.(css|js|png|jpg|jpeg)(\?v=\d+)?)""";
string input = @"<link rel=""stylesheet"" media=""print"" href=""common/css/print.css?v=20111230"">
<link rel=""stylesheet"" href=""doc/docs.css"">
<img src=""common/logos/logo-mysql-110x57.png"" alt=""MySQL"" width=""110"" height=""57"">
<script src=""common/js/metrics/s_code_remote.js""></script>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}