// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(src|href)="([0-9a-zA-Z_\-\/]+\.(css|js|png|jpg|jpeg)(\?v=\d+)?)""#).unwrap();
let string = "<link rel=\"stylesheet\" media=\"print\" href=\"common/css/print.css?v=20111230\">
<link rel=\"stylesheet\" href=\"doc/docs.css\">
<img src=\"common/logos/logo-mysql-110x57.png\" alt=\"MySQL\" width=\"110\" height=\"57\">
<script src=\"common/js/metrics/s_code_remote.js\"></script>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}