#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(UNION ALL\D*?historical;)"
Local $sString = "@b =" & @CRLF & _
" SELECT *" & @CRLF & _
" FROM @e;" & @CRLF & _
" UNION ALL" & @CRLF & _
" SELECT *" & @CRLF & _
" FROM @c_historical;" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"@r =" & @CRLF & _
" SELECT *" & @CRLF & _
" FROM @f;" & @CRLF & _
" UNION ALL" & @CRLF & _
" SELECT *" & @CRLF & _
" FROM @y_historical;"
Local $sSubst = "\/\*\1\*\/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)