using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(UNION ALL\D*?historical;)";
string substitution = @"\/\*\1\*\/";
string input = @"@b =
SELECT *
FROM @e;
UNION ALL
SELECT *
FROM @c_historical;
@r =
SELECT *
FROM @f;
UNION ALL
SELECT *
FROM @y_historical;";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}