package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(UNION ALL\D*?historical;)`)
var str = `@b =
SELECT *
FROM @e;
UNION ALL
SELECT *
FROM @c_historical;
@r =
SELECT *
FROM @f;
UNION ALL
SELECT *
FROM @y_historical;`
var substitution = "\/\*\1\*\/"
fmt.Println(re.ReplaceAllString(str, substitution))
}