use strict;
my $str = '@b =
SELECT *
FROM @e;
UNION ALL
SELECT *
FROM @c_historical;
@r =
SELECT *
FROM @f;
UNION ALL
SELECT *
FROM @y_historical;';
my $regex = qr/(UNION ALL\D*?historical;)/mp;
my $subst = '\\/\\*\\1\\*\\/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";