re = /(UNION ALL\D*?historical;)/m
str = '@b =
SELECT *
FROM @e;
UNION ALL
SELECT *
FROM @c_historical;
@r =
SELECT *
FROM @f;
UNION ALL
SELECT *
FROM @y_historical;'
subst = '\\/\\*\\1\\*\\/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result