using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^http(s)?://i\.redd\.it/\w+\.(png|gif|jpg|jpeg)$";
string input = @"https://i.redd.it/somestr1ng.png";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}