re = /^http(s)?:\/\/i\.redd\.it\/\w+\.(png|gif|jpg|jpeg)$/m
str = 'https://i.redd.it/somestr1ng.png'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end