package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z]+\s((\/\w+)*\/)([\w\-\.]+[^#?\s]+)`)
var str = `GET /context/path/to/file.js
https://stackoverflow.com/questions/27745/getting-parts-of-a-url-regex`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}