$re = '/^https:\/\/www\.roblox\.com\/games\/\d{1,}\/?[a-zA-Z0-9]+(?:-[a-zA-Z0-9]+)*$/';
$str = 'https://www.roblox.com/games/12345678/GameName';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);