# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".+? (?<name>.+) \((?<points>\d+) points?\)\n(?:When input is\n(?<input>.*?)\n)?Standard output (?<condition>.+?)\n(?<output>.+)\nEdit\nClone\nRemove\n"
test_str = ("\"1. Compare output (2 points)\n"
"Standard output exactly matches\n"
"Character 'p' is a letter\n"
"Character ' ' is a white space\n"
"Character '2' is a digit\n"
"Character '!' is unknown\n\n"
"Edit\n"
"Clone\n"
"Remove\n\n"
"----\n\n"
"1. Compare output (2 points)\n"
"When input is\n"
"xxxtoyxxx\n"
"Standard output exactly matches\n"
"Midfix: toy\n\n"
"Edit\n"
"Clone\n"
"Remove")
matches = re.search(regex, test_str, re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.