re = /.+? (?<name>.+) \((?<points>\d+) points?\)\n(?:When input is\n(?<input>.*?)\n)?Standard output (?<condition>.+?)\n(?<output>.+)\nEdit\nClone\nRemove\n/
str = '"1. Compare output (2 points)
Standard output exactly matches
Character \'p\' is a letter
Character \' \' is a white space
Character \'2\' is a digit
Character \'!\' is unknown
Edit
Clone
Remove
----
1. Compare output (2 points)
When input is
xxxtoyxxx
Standard output exactly matches
Midfix: toy
Edit
Clone
Remove'
# Print the match result
str.match(re) do |match|
puts match.to_s
end