# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^(?!.*bar).*)| /\1\t/gm;t' <<< "foo: here is some sample text
bar: here is some sample text"