import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(I1|I2|I3|I4|I5|I6|II|III|IV|V|VI|VII|VIII|IX|X|XI|XII|XIII|XIV|XV|XVI|XVII|XVIII|XIX)$";
final String string = "I1\n"
+ "I2\n"
+ "I3\n"
+ "I4\n"
+ "I5\n"
+ "I6\n"
+ "II\n"
+ "III\n"
+ "IV\n"
+ "V\n"
+ "VI\n"
+ "VII\n"
+ "VIII\n"
+ "IX\n"
+ "X\n"
+ "XI\n"
+ "XII\n"
+ "XIII\n"
+ "XIV\n"
+ "XV\n"
+ "XVI\n"
+ "XVII\n"
+ "XVIII\n"
+ "XIX";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}