#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/(test|foo|en|ppp|bar\/baz)(\/?((?<!bar\/baz\/?)\?\w+=\w+|[-\w]+))*\/?$"
Local $sString = "www.mysite.com/bar/baz/?uid=100/" & @CRLF & _
"www.mysite.com/bar/baz?uid=100" & @CRLF & _
"www.mysite.com/bar/baz" & @CRLF & _
"www.mysite.com/bar/baz/en/?uid=100" & @CRLF & _
"www.mysite.com/bar/baz/en/?uid=100/" & @CRLF & _
"www.mysite.com/en/bar/baz/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")