$re = '/\/(test|foo|en|ppp|bar\/baz)(\/?((?<!bar\/baz\/?)\?\w+=\w+|[-\w]+))*\/?$/m';
$str = 'www.mysite.com/bar/baz/?uid=100/
www.mysite.com/bar/baz?uid=100
www.mysite.com/bar/baz
www.mysite.com/bar/baz/en/?uid=100
www.mysite.com/bar/baz/en/?uid=100/
www.mysite.com/en/bar/baz/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);