$re = '/\b\.\S+:?\b/m';
$str = 'a.abc
a.abc:bcd
a.abc: bcd
.abc
.abc:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);