const regex = /^[a-z](?!\w*__)(?:\w*[^\W_])?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z](?!\\w*__)(?:\\w*[^\\W_])?$', 'gm')
const str = `somestring
_not_this_one
thisone_
neither this one
but_this_one
this__one_not
this_one__yes
a
b
cd
c_
c__d
c_d`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}