$re = '/^.*?(?:!([^!\n]*?))?(?:\.(\d{3}))?$/m';
$str = 'aaaaa!bbbb.200
aaa.400
aaa!bb
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);