using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:\w*?[aeiou]{2}){2}\w*\b";
string input = @"that contain 2 or more 2 letter sequences of vowels (e.g. visionproof, steamier, preequip).";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}