import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^E\\h+|\\G(?!^),?(\\d{1,4}-\\d{1,4}))";
final String string = "E 1-6,44-80\n"
+ "E 10-76\n"
+ "E 44-80,233-425\n"
+ "E 19-55,62-83,86-119,200-390\n\n"
+ "200-390";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}