const regex = /:value=(".*)@input=(".*?")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(':value=(".*)@input=(".*?")', 'gm')
const str = `<VSection :value="..." key=keyid @input="..." title="Infer an AI Model">
`;
const subst = `:model-value=$1@update:model-value=$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);