use strict;
my $str = 'from ab1c_table in WXY
previous in time
from abc3_table in MNO
previous in time
';
my $regex = qr/\bfrom \w+ in (\w+)\nprevious in time\b/mp;
my $subst = '<font color="#FF4500"><b>$0</b></font>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";