using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=groups\/)(?<id>[0-9]+)|(?<=groups\/)(?<username>[a-zA-Z\.\_0-9]+)";
string input = @"https://www.facebook.com/groups/164062097331207/?ref=group_browse_new
https://www.facebook.com/groups/j2team.community/?ref=group_browse_new
https://www.facebook.com/groups/j2team.community.banned/?ref=group_browse_new";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}