#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)#[ \t]*include[ \t]+(\"|<)([^>\"]+)(?:\"|>)"
Local $sString = "#include "stdafx.h"" & @CRLF & _
"#include <iostream>" & @CRLF & _
"# include <avr32/uc3c0128c.h>" & @CRLF & _
"#include "../my_path/header.h"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")