$re = '/#[ \t]*include[ \t]+(\"|<)([^>\"]+)(?:\"|>)/m';
$str = '#include "stdafx.h"
#include <iostream>
# include <avr32/uc3c0128c.h>
#include "../my_path/header.h"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);