#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b6(?:011|5[0-9]{2})[ -]([0-9]{4}[ -]){2}([0-9]{4})\b|\b6(?:011|5[0-9]{2})(?:[0-9]{12})?$\b"
Local $sString = "Discover" & @CRLF & _
"" & @CRLF & _
"Requirements: Discover cards start with the number 6011 or 65 and have 16 digits. " & @CRLF & _
"" & @CRLF & _
"Pattern Parts:" & @CRLF & _
"Starts with number 6011 or 65, has 16 length, and has space or dash:" & @CRLF & _
"1) \b6(?:011|5[0-9]{2})[ -]([0-9]{4}[ -]){2}([0-9]{4})\b" & @CRLF & _
"" & @CRLF & _
"Starts with number 6011 or 65, has 16 length, and has no space or dash:" & @CRLF & _
"2) \b6(?:011|5[0-9]{2})(?:[0-9]{12})?$\b" & @CRLF & _
"" & @CRLF & _
"Combining 1-2 to form one pattern:" & @CRLF & _
"\b6(?:011|5[0-9]{2})[ -]([0-9]{4}[ -]){2}([0-9]{4})\b|\b6(?:011|5[0-9]{2})(?:[0-9]{12})?$\b" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Test Cases:" & @CRLF & _
"Positive (Should fire):" & @CRLF & _
"16 length, no space, start with 6011 6011123412341234" & @CRLF & _
"16 length, dashes, start with 6011 6011-1234-1234-1234" & @CRLF & _
"16 length, spaces, start with 6011 6011 1234-1234-1234" & @CRLF & _
"" & @CRLF & _
"16 length, no space, start with 65 6521123412341234" & @CRLF & _
"16 length, dashes, start with 65 6521-1234-1234-1234" & @CRLF & _
"16 length, spaces, start with 65 6521 1234 1234 1234" & @CRLF & _
"" & @CRLF & _
"Embedded in sentence with space:" & @CRLF & _
"16 length, no space, start with 6011 Here is the cc: 6011123412341234" & @CRLF & _
"16 length, dashes, start with 6011 Here is the cc: 6011-1234-1234-1234" & @CRLF & _
"16 length, spaces, start with 6011 Here is the cc: 6011 1234-1234-1234" & @CRLF & _
"" & @CRLF & _
"16 length, no space, start with 65 Here is the cc: 6521123412341234" & @CRLF & _
"16 length, dashes, start with 65 Here is the cc: 6521-1234-1234-1234" & @CRLF & _
"16 length, spaces, start with 65 Here is the cc: 6523 1234-1234-1234" & @CRLF & _
"" & @CRLF & _
"16 length, no space, start with 6011 Credit Card#:6011123412341234" & @CRLF & _
"16 length, dashes, start with 6011 Credit Card#:6011-1234-1234-1234" & @CRLF & _
"16 length, spaces, start with 6011 Credit Card#:6011 1234-1234-1234" & @CRLF & _
"" & @CRLF & _
"16 length, no space, start with 65 Credit Card#:6521123412341234" & @CRLF & _
"16 length, dashes, start with 65 Credit Card#:6521-1234-1234-1234" & @CRLF & _
"16 length, spaces, start with 65 Credit Card#:6523 1234-1234-1234" & @CRLF & _
"" & @CRLF & _
"Negative (Should Not Fire):" & @CRLF & _
"16 length, no space, not start with 6012 6012123412341234" & @CRLF & _
"16 length, dashes, not start with 6012 6012-1234-1234-1234" & @CRLF & _
"16 length, spaces, not start with 6012 6012 1234 1234 1234" & @CRLF & _
"" & @CRLF & _
"16 length, no space, not start with 66 6612123412341234" & @CRLF & _
"16 length, dashes, not start with 66 6612-1234-1234-1234" & @CRLF & _
"16 length, spaces, not start with 66 6612-1234-1234-1234" & @CRLF & _
"" & @CRLF & _
"16 length, no space, start with 65, embedded Credit Card Number6521123412341234" & @CRLF & _
"16 length, dashes, start with 6011, malformed 601-11234-1234-1234" & @CRLF & _
"" & @CRLF & _
"16 length num matching pattern but embedded User ID: 0000006011123412341234000000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")