# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b6(?:011|5[0-9]{2})[ -]([0-9]{4}[ -]){2}([0-9]{4})\b|\b6(?:011|5[0-9]{2})(?:[0-9]{12})?$\b"
test_str = ("Discover\n\n"
"Requirements: Discover cards start with the number 6011 or 65 and have 16 digits. \n\n"
"Pattern Parts:\n"
"Starts with number 6011 or 65, has 16 length, and has space or dash:\n"
"1) \\b6(?:011|5[0-9]{2})[ -]([0-9]{4}[ -]){2}([0-9]{4})\\b\n\n"
"Starts with number 6011 or 65, has 16 length, and has no space or dash:\n"
"2) \\b6(?:011|5[0-9]{2})(?:[0-9]{12})?$\\b\n\n"
"Combining 1-2 to form one pattern:\n"
"\\b6(?:011|5[0-9]{2})[ -]([0-9]{4}[ -]){2}([0-9]{4})\\b|\\b6(?:011|5[0-9]{2})(?:[0-9]{12})?$\\b\n\n\n"
"Test Cases:\n"
"Positive (Should fire):\n"
"16 length, no space, start with 6011 6011123412341234\n"
"16 length, dashes, start with 6011 6011-1234-1234-1234\n"
"16 length, spaces, start with 6011 6011 1234-1234-1234\n\n"
"16 length, no space, start with 65 6521123412341234\n"
"16 length, dashes, start with 65 6521-1234-1234-1234\n"
"16 length, spaces, start with 65 6521 1234 1234 1234\n\n"
"Embedded in sentence with space:\n"
"16 length, no space, start with 6011 Here is the cc: 6011123412341234\n"
"16 length, dashes, start with 6011 Here is the cc: 6011-1234-1234-1234\n"
"16 length, spaces, start with 6011 Here is the cc: 6011 1234-1234-1234\n\n"
"16 length, no space, start with 65 Here is the cc: 6521123412341234\n"
"16 length, dashes, start with 65 Here is the cc: 6521-1234-1234-1234\n"
"16 length, spaces, start with 65 Here is the cc: 6523 1234-1234-1234\n\n"
"16 length, no space, start with 6011 Credit Card#:6011123412341234\n"
"16 length, dashes, start with 6011 Credit Card#:6011-1234-1234-1234\n"
"16 length, spaces, start with 6011 Credit Card#:6011 1234-1234-1234\n\n"
"16 length, no space, start with 65 Credit Card#:6521123412341234\n"
"16 length, dashes, start with 65 Credit Card#:6521-1234-1234-1234\n"
"16 length, spaces, start with 65 Credit Card#:6523 1234-1234-1234\n\n"
"Negative (Should Not Fire):\n"
"16 length, no space, not start with 6012 6012123412341234\n"
"16 length, dashes, not start with 6012 6012-1234-1234-1234\n"
"16 length, spaces, not start with 6012 6012 1234 1234 1234\n\n"
"16 length, no space, not start with 66 6612123412341234\n"
"16 length, dashes, not start with 66 6612-1234-1234-1234\n"
"16 length, spaces, not start with 66 6612-1234-1234-1234\n\n"
"16 length, no space, start with 65, embedded Credit Card Number6521123412341234\n"
"16 length, dashes, start with 6011, malformed 601-11234-1234-1234\n\n"
"16 length num matching pattern but embedded User ID: 0000006011123412341234000000")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.