#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\-{0,1})(?:(?:0*)(\d+))?((?:\.)(?:\d*?))?0*$"
Local $sString = "-0.002506000" & @CRLF & _
"1" & @CRLF & _
"01" & @CRLF & _
"10" & @CRLF & _
"1.25" & @CRLF & _
"01.250" & @CRLF & _
"0" & @CRLF & _
"0002345000" & @CRLF & _
"0.25" & @CRLF & _
"0.50" & @CRLF & _
"0.5" & @CRLF & _
"0.75000" & @CRLF & _
"1000" & @CRLF & _
"0001.111" & @CRLF & _
"0001.5" & @CRLF & _
".25" & @CRLF & _
"01234" & @CRLF & _
"-00.1" & @CRLF & _
".2500" & @CRLF & _
".0256" & @CRLF & _
"-.010"
Local $sSubst = "$1$2$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)