const regex = /.+? (.+) \((\d+) points?\)\nWhen input is\n(.*?)\nStandard output (.+?)\n(.+)\nEdit\nClone\nRemove/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.+? (.+) \\((\\d+) points?\\)\\nWhen input is\\n(.*?)\\nStandard output (.+?)\\n(.+)\\nEdit\\nClone\\nRemove', 's')
const str = `"1. Compare output (2 points)
When input is
xxxtoyxxx
Standard output exactly matches
Midfix: toy
Edit
Clone
Remove`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}