import re
regex = re.compile(r"^(?=.*[а-я])(?=.*[А-Я])[а-яА-Я]+$", flags=re.MULTILINE)
test_str = ("qwerty1\n"
"QWERTY1q\n"
"qwERTy\n"
"QWERTY1\n"
"QWER TY1q\n\n"
"Мама\n"
"авТо\n"
"гриБ\n"
"Яблоко\n"
"яБлоко\n"
"ябЛоко\n"
"яблОко\n"
"яблоКо\n"
"яблокО\n\n\n"
"агент007\n"
"стриж\n"
"ГТО\n"
"Три богатыря")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)