#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^service\/([^\/])(.*)\/vdnh\/?$"
Local $sString = "service/bla-bla/blu-blu-bli/" & @CRLF & _
"service/bla-bla/blu-blu-bli/qwerty/" & @CRLF & _
"service/bla-bla/blu-blu-bli/qwerty/page44/" & @CRLF & _
"service/bla-bla/blu-blu-bli/vdnh/" & @CRLF & _
"service/bla-bla/blu-blu-bli/qwerty/page44/vdnh"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")