const regex = /^service\/([^\/])(.*)\/vdnh\/?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^service\\\/([^\\\/])(.*)\\\/vdnh\\\/?$', 'gm')
const str = `service/bla-bla/blu-blu-bli/
service/bla-bla/blu-blu-bli/qwerty/
service/bla-bla/blu-blu-bli/qwerty/page44/
service/bla-bla/blu-blu-bli/vdnh/
service/bla-bla/blu-blu-bli/qwerty/page44/vdnh`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}