$re = '/T40[0-9][0-9][.][a-zA-Z]+/m';
$str = 'T4018.test.12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);