const regex = /(\/)(?:[A-Z2-7]{8})*(?:[A-Z2-7]{2}={6}|[A-Z2-7]{4}={4}|[A-Z2-7]{5}={3}|[A-Z2-7]{7}=)?(\/|$)|(\/)(\d*?)(\/|$)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/)(?:[A-Z2-7]{8})*(?:[A-Z2-7]{2}={6}|[A-Z2-7]{4}={4}|[A-Z2-7]{5}={3}|[A-Z2-7]{7}=)?(\\\/|$)|(\\\/)(\\d*?)(\\\/|$)', '')
const str = `/emrc/patient/123`;
const subst = `/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);