#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\[(?'id'[0-9]+)\])?(?'name'[^[.]+|.+)?(?:\[(?'data'[.\-:0-9 ]+)\])?(?'ext'\.[.a-zA-Z]+)+$"
Local $sString = "[2013]Test1 [23.12.2020 13-34].zip" & @CRLF & _
"[2013]Test1 .zip" & @CRLF & _
"Test1 [23.12.2020 13-34].zip" & @CRLF & _
"Test1 .zip" & @CRLF & _
"[]Test1 [].zip" & @CRLF & _
"Te[]st[]1 .zip" & @CRLF & _
"[][].zip" & @CRLF & _
"[].zip" & @CRLF & _
".zip" & @CRLF & _
".zip.zip" & @CRLF & _
"[]~[1.1,+'_!@#$%^&()].zip" & @CRLF & _
"hello[23.12.2020 13-34]world.zip"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")