package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\[(?'id'[0-9]+)\])?(?'name'[^[.]+|.+)?(?:\[(?'data'[.\-:0-9 ]+)\])?(?'ext'\.[.a-zA-Z]+)+$`)
var str = `[2013]Test1 [23.12.2020 13-34].zip
[2013]Test1 .zip
Test1 [23.12.2020 13-34].zip
Test1 .zip
[]Test1 [].zip
Te[]st[]1 .zip
[][].zip
[].zip
.zip
.zip.zip
[]~[1.1,+'_!@#$%^&()].zip
hello[23.12.2020 13-34]world.zip`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}