import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\[(?'id'[0-9]+)\\])?(?'name'[^[.]+|.+)?(?:\\[(?'data'[.\\-:0-9 ]+)\\])?(?'ext'\\.[.a-zA-Z]+)+$";
final String string = "[2013]Test1 [23.12.2020 13-34].zip\n"
+ "[2013]Test1 .zip\n"
+ "Test1 [23.12.2020 13-34].zip\n"
+ "Test1 .zip\n"
+ "[]Test1 [].zip\n"
+ "Te[]st[]1 .zip\n"
+ "[][].zip\n"
+ "[].zip\n"
+ ".zip\n"
+ ".zip.zip\n"
+ "[]~[1.1,+'_!@#$%^&()].zip\n"
+ "hello[23.12.2020 13-34]world.zip";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}