use strict;
my $str = '[2013]Test1 [23.12.2020 13-34].zip
[2013]Test1 .zip
Test1 [23.12.2020 13-34].zip
Test1 .zip
[]Test1 [].zip
Te[]st[]1 .zip
[][].zip
[].zip
.zip
.zip.zip
[]~[1.1,+\'_!@#$%^&()].zip
hello[23.12.2020 13-34]world.zip';
my $regex = qr/^(?:\[(?'id'[0-9]+)\])?(?'name'[^[.]+|.+)?(?:\[(?'data'[.\-:0-9 ]+)\])?(?'ext'\.[.a-zA-Z]+)+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}