using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(Step.*)(Description.*)";
string input = @"/**
* @company-gherkin: Step: go to the list. Description: Navigates to the list.
*/";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}