re = /(Step.*)(Description.*)/
str = '/**
* @company-gherkin: Step: go to the list. Description: Navigates to the list.
*/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end