# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"GigabitEthernet1\/1\/1(?:(?!interface GigabitEthernet)[\s\S])*(vlan.*40(?:9[12]|[6-8][0-9]|5[2-9]))"
test_str = ("interface GigabitEthernet1/1/1\n"
" description link-to-someswitch-Gi2/0/1\n"
" switchport access vlan 3109\n"
" switchport trunk allowed vlan 300,301,350,358,800,3109\n"
" switchport trunk encapsulation dot1q\n"
" switchport trunk native vlan 3109\n"
" switchport mode dynamic desirable\n"
" srr-queue bandwidth share 40 20 20 20\n"
" srr-queue bandwidth shape 10 0 0 0\n"
" priority-queue out \n"
" no snmp trap link-status\n"
" mls qos trust dscp\n"
" spanning-tree portfast disable\n"
"!\n"
"interface GigabitEthernet1/1/2\n"
" description link-to-someswitch2-Gi2/0/1\n"
" switchport access vlan 3609\n"
" switchport trunk allowed vlan 300,301,350,358,800,3609,4088\n"
" switchport trunk encapsulation dot1q\n"
" switchport trunk native vlan 3109\n"
" switchport mode dynamic desirable\n"
" srr-queue bandwidth share 40 20 20 20\n"
" srr-queue bandwidth shape 10 0 0 0\n"
" priority-queue out \n"
" no snmp trap link-status\n"
" mls qos trust dscp\n"
" spanning-tree portfast disable\n\n"
"interface GigabitEthernet1/1/1\n"
" description link-to-someswitch-Gi2/0/1\n"
" switchport access vlan 3109\n"
" switchport trunk allowed vlan 300,301,350,358,800,4088\n"
" switchport trunk encapsulation dot1q\n"
" switchport trunk native vlan 3109\n"
" switchport mode dynamic desirable\n"
" srr-queue bandwidth share 40 20 20 20\n"
" srr-queue bandwidth shape 10 0 0 0\n"
" priority-queue out \n"
" no snmp trap link-status\n"
" mls qos trust dscp\n"
" spanning-tree portfast disable\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.