re = /(?<=Bid\/Ask<\/TD>)[\s\S]*?(\d{1,4}\.\d{2})[\s\S]*?(\d{1,4}\.\d{2})[\s\S]*?(?=Low\/High<\/TD>)[\s\S]*?(\d{1,4}\.\d{2})[\s\S]*?(\d{1,4}\.\d{2})[\s\S]*?(?=Change<\/TD>)[\s\S]*?((?:\+|-)\d{1,4}\.\d{2})[\s\S]*?((?:\+|-)\d{1,4}\.\d{2}%)/m
str = '
<!--THE BID ASK TAG-->
<TR class="spot" bgColor=\'#f1f1f1\'>
<TD>Bid/Ask</TD> <TD
align=\'middle\' ><font
color=\'\'>15.73</font></TD>
<TD align=\'middle\' > </TD>
<TD align=\'middle\' ><font
color=\'\'>15.83</font></TD>
</TR>
<TR class="spot" bgColor=\'\'>
<TD>Low/High</TD> <TD
align=\'middle\' ><font
color=\'\'>15.51</font></TD>
<TD align=\'middle\' > </TD>
<TD align=\'middle\' ><font
color=\'\'>15.86</font></TD>
</TR>
<TR class="spot" bgColor=\'#f1f1f1\'>
<TD>Change</TD> <TD
align=\'middle\' ><font
color=\'green\'>+0.12</font></TD>
<TD align=\'middle\' > </TD>
<TD align=\'middle\' ><font
color=\'green\'>+0.74%</font></TD>
</TR>
<TR class="spot" bgColor=\'\'>
<TD>30DayChg</TD> <TD
align=\'middle\' ><font
color=\'green\'>+1.23</font></TD>
<TD align=\'middle\' > </TD>
<TD align=\'middle\' ><font
color=\'green\'>+8.49%</font></TD>
</TR>
<TR class="spot" bgColor=\'#f1f1f1\'>
<TD>1YearChg</TD> <TD
align=\'middle\' ><font
color=\'red\'>-1.21</font></TD>
<TD align=\'middle\' > </TD>
<TD align=\'middle\' ><font
color=\'red\'>-7.14%</font></TD>
</TR>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end