using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[+-]?[0-9][0-9]*(\.[0-9]*)?\b";
string input = @"twentyseven27
27, 56, -151.43, +15350.16f, (the boundary avoids to accept the fractional part)
e37, e+25.42, (the + acts as a boundary, so it scans the number correctly)
e25.42 (look at this... we should avoid this)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}